SSL/TLS 证书已成为值得重视的 Web 安全方案,但仍有许多人不了解 SSL 及其核心实践。在现代网络犯罪时代,忽视 Web 安全可能让企业陷入资金与声誉损失的困境。一些网站因未从客户利益出发而忽略 SSL/TLS 的使用。本文旨在鼓励网站所有者实施 SSL,并介绍 SSL 中常用的若干术语。
为什么你的网站需要 SSL 或 TLS 证书?
SSL 证书具备使其脱颖而出的固有特性。HTTPS 加密不仅是 SSL 的目标,还提供业务身份认证、数据隐私与便捷的信息交换。按最新 NIST 与 CA/浏览器准则,每张 SSL/TLS 证书都采用现代且强健的算法保障在线环境安全。
1. 身份认证:用户访问网站时,服务器向浏览器发送证书副本,表明其正连接正确网站;服务器证书数据含域名与公司信息,浏览器在访问 SSL 安全站点时显示绿色挂锁,向访客保证站点可安全交易。
2. 数据完整性:SSL 确保传输中数据不被篡改;借助强加密,网络攻击者无法破坏或更改用户与 Web 服务器间的内容,消息/数据通过消息认证码(MAC)确认。
3. 数据机密性:防止数据暴露给第三方或攻击者;加密数据难以被拦截,从而在两端点间保持机密。
SSL 与 TLS 协议解析
在密码学领域,主要有 SSL(Secure Socket Layer)与 TLS(Transport Layer Security)两类协议,广泛用于多数邮件、应用与 VoIP 场景。
关于 SSL 协议:SSL 主要有 1.0、2.0、3.0 三个版本,现均已弃用,目前 TLS 1.2 生效。SSL 由 Netscape 开发:SSL 1.0 因安全缺陷从未公开发布;SSL 2.0(1995 年 2 月)同样因安全缺陷表现不佳,易受 DROWN 攻击,且即便不同服务器使用同一公钥证书,也可被用于攻击同名 RSA 密钥,还会泄露可被用于攻击 TLS 服务器的公钥细节;SSL 3.0(1996 年)支持证书认证并加入基于 SHA-1 的密码,但密钥派生过程薄弱(主密钥依赖 MD5 哈希,易遭碰撞攻击),2014 年 10 月被认定易受填充攻击,但 SSL 3.0 建立的证书链使组织可使用证书层级。
关于 TLS 协议:TLS 迄今主要发布三个版本。TLS 1.0 定义于 1999 年 1 月 RFC2246,基于对称加密(DES、RC4),每连接生成唯一密钥并基于会话开始时协商的共享秘密;TLS 1.1 规范于 2006 年 4 月 RFC4346,是 TLS 1.0 的升级,可理想防护 CBC(密码块链接)攻击,支持 IANA 注册参数;TLS 1.2 规范于 2008 年 8 月 RFC5246,带来现代认证加密,目前被接受并认为免遭任何已知攻击。
如何获取 SSL/TLS 证书?
SSL 订购流程遵循以下简单步骤:
1. 首先,根据需求选择所需的 SSL 产品类型(域名型、通配符、多域名/SAN 等)。
2. 在服务器上创建 CSR(证书签名请求)并复制到记事本。
3. 根据业务需要购买 SSL/TLS 证书产品。
4. 付款后,你会收到唯一的配置链接。
5. 提交生成的 CSR 以启动认证流程并等待订单审核。
6. 证书颁发机构通过邮件发送你的 SSL 证书。
7. 将证书安装到目标服务器,并记得在网站上部署「安全站点印章」。
推荐 SSL/TLS 术语表
CSR(证书签名请求):包含组织名称、域名、地点、城市、邮箱等信息,在订购证书时提交;CA 据此确认并创建你的 SSL 证书,最重要的是它还包含将写入证书的公钥。
不同类型的 SSL/TLS 验证:
1. 域名验证(DV)SSL:CA 验证域名所有权,确认域名属于申请者,可在 15 分钟内签发。
2. 组织验证(OV)SSL:建立企业身份,需相关业务文件验证企业存续。
3. 扩展验证(EV)SSL:遵循严格冗长流程,含域名与企业验证,按 EV 指南核查实体的法律、运营与物理存在。
站点印章:购买 SSL 证书时免费提供,是一种向访客与客户保证网站安全的 Logo,表明任何在线交易都在安全环境中进行。
公钥密码学:密钥在基于非对称加密的 SSL 证书中至关重要,包括私钥与公钥;用公钥加密的数据只能由私钥解密,强密钥意味着被窥探与拦截的概率更低。
公钥与私钥:公钥是非对称密码学的一部分,使用公钥-私钥对,公钥在用户间传播,用公钥加密的消息只能由私钥解密;这种双密钥体系称为非对称密码学,使用公钥的系统称为 PKI(公钥基础设施)。私钥用于解密,当前许多 CA 使用 2048 位 RSA 密钥,建议在受信任且有妥善安全的计算机上生成私钥。
可靠的证书颁发机构:在线身份的保障需由合法 CA 背书的认证 SSL 证书实现;自签名证书缺乏可靠性,浏览器遇之会警告。合法 CA 确保浏览器与服务器间传输信息被强加密,第三方无法拦截。当前领先的 CA 已在 SSL 行业确立地位。
根 SSL 证书:含根证书与中级证书两种;为使证书被设备与浏览器信任,根证书发挥作用——它由 CA 创建并被软件应用与浏览器识别,用于建立信任链,浏览器信任所有由根证书签名的证书。用户访问网站时,浏览器沿根证书建立的信任链启动验证。
ECC 算法:随着 RSA 密钥增大可能引发性能问题,ECC(椭圆曲线密码学)以更小更快的密钥生成提供同等加密强度,164 位 ECC 密钥的安全级别相当于 1024 位 RSA 密钥。
Always-On SSL(全时 SSL):一种误解认为 SSL 仅用于登录或结账页,这并不正确——当你保护特定页面时,网站其余页面仍处未加密状态,黑客可利用这些页面。因此 Always-On SSL 可保护整个网站(含图片、JavaScript、Cookie 与会话),避免 Sidejacking 与 SSL 剥离攻击。SSL 是创建安全隧道、在受保护环境传输信息的协议;以上信息是关于 SSL 最佳实践的快速指南,可助你在选用 SSL 证书或了解行业实践时参考。